summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 442449619dea..9913c68b02c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,9 @@
+_orig_ver=1.11.2
+_orig_patch=c
+_orig_fullver=$_orig_ver$_orig_patch
+
pkgname=bandwidth
-pkgver=1.11.2
+pkgver=$_orig_ver${_orig_patch:+.$_orig_patch}
pkgrel=1
pkgdesc="Benchmark memory bandwidth"
arch=('i686' 'x86_64')
@@ -7,11 +11,18 @@ url="http://zsmith.co/bandwidth.php"
license=('GPL')
makedepends=('nasm')
options=(!makeflags !debug)
-sha256sums=('9a3b6f400387f6bbf5d97b3319d0f98485f5f7b7abed473be167d568fdf64e93')
-source=("https://zsmith.co/archives/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1f4cc154424c811e66fc9eb96d66a8ed8e874f6900398e666acbda2a1fd562fd'
+ '3d997fa73b24608ae47d02849b8fd63e5168327b1be3f2fa6088317282c8d91b')
+source=("https://zsmith.co/archives/${pkgname}-${_orig_fullver}.tar.gz"
+ make-clean-fix.patch)
+
+prepare() {
+ cd "${srcdir}"
+ patch -N -p0 -d "${pkgname}-${_orig_fullver}" < ../make-clean-fix.patch
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
make clean
@@ -23,7 +34,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
if [ "${CARCH}" = "x86_64" ]; then
install -Dm755 bandwidth64 "${pkgdir}"/usr/bin/bandwidth
else