summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ceec1c8c4f4a..9b91a1a65d23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
pkgname=bandwidthd
_repouser=post-factum
_reponame=bandwidthd
-pkgver=2.0.11
-pkgrel=2
+pkgver=2.0.13
+pkgrel=1
epoch=1
pkgdesc="Daemon for graphing traffic of subnet machines"
arch=(x86_64)
url="https://codeberg.org/post-factum/bandwidthd"
license=(GPL)
-depends=(sqlite libpcap libpng gd nginx)
+depends=(sqlite libpcap libpng gd)
makedepends=(meson)
-source=(${pkgname}-${pkgver}.tar.gz::https://codeberg.org/${_repouser}/${_reponame}/archive/v${pkgver}.tar.gz)
+source=(https://codeberg.org/${_repouser}/${_reponame}/archive/v${pkgver}.tar.gz)
-sha256sums=('e9a42e675012ab3c95e9d968a67c1c3fa53d41b1cc81205a7f3625d5a85c94ea')
+sha256sums=('e4761abe5e06a7ff1ecde7643d54c45390f33129c6de074fbd4df74e3c26f740')
backup=('etc/bandwidthd/bandwidthd.conf'
- 'etc/bandwidthd/bandwidthd-webui.conf')
+ 'etc/bandwidthd/Caddyfile')
build() {
cd ${_reponame}
@@ -28,6 +28,8 @@ build() {
}
package() {
+ depends+=(caddy)
+
cd ${_reponame}
meson install -C build --destdir "${pkgdir}"