summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d038b523d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=barpyrus-git
+pkgver=r71.42fb779
+pkgrel=1
+pkgdesc="A python wrapper for lemonbar/conky"
+arch=(any)
+url="https://github.com/t-wissmann/barpyrus"
+license=('BSD')
+depends=('python' 'python-setuptools' 'lemonbar' 'siji-git' 'herbstluftwm')
+optdepends=('conky: To use the conky widget')
+source=("git+https://github.com/t-wissmann/barpyrus.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd barpyrus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd barpyrus
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: