summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 802ee2f506f0..45fbbdd798f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Hauke Wesselmann <hauke at h-dawg.de>
pkgname=barry
-pkgver=0.18.4
-pkgrel=6
+pkgver=0.18.5
+pkgrel=1
pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
url=('http://www.netdirect.ca/software/packages/barry')
license=('GPL')
@@ -14,13 +14,13 @@ optdepends=('fuse: for mounting the BB database with bfuse'
'ppp: for tethering with pppob')
options=('!libtool')
install=(${pkgname}.install)
-source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-0.18.4/sources/debian/${pkgname}_${pkgver}.orig.tar.gz"
"${pkgname}.desktop"
"fix-sizeof-use.patch"
"wx3.0-compat.patch"
"c++11.patch")
-sha256sums=('4036d9eb46a86794455f9f125e8d77dd922e06f74889c5be7f35554be3f48a73'
- 'cb30b64a392ff5ff0482399cd31e6c997c57e60969145680497a54ffbb8f7d67'
+sha256sums=('66cd913bcfcb5dc0fc3dfcbe8c375845d51649d573c321acba46b96b1bc0059e'
+ 'aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21'
'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3'
'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c')
@@ -32,10 +32,7 @@ prepare() {
patch -Np1 -i "${srcdir}/fix-sizeof-use.patch"
patch -Np1 -i "${srcdir}/wx3.0-compat.patch"
- # Disable Werror
- find /$(pwd) -type f -exec sed -i 's/-Werror//g' '{}' \;
-
- #C++11 compatibility
+ # C++11 compatibility
patch -Np1 -i "${srcdir}/c++11.patch"
autoreconf -fi
@@ -45,6 +42,7 @@ build() {
cd ${srcdir}/${pkgname}-${pkgver}
export CXXFLAGS="-std=c++11"
+ export CPPFLAGS="-Wno-error"
./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin \
--enable-gui \