summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 2 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9e79c16916c..878a212f98a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=barry
pkgver=0.18.5
-pkgrel=8
+pkgrel=9
pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
url=https://github.com/NetDirect/barry
license=('GPL')
@@ -14,20 +14,14 @@ optdepends=('fuse2: for mounting the BB database with bfuse'
'ppp: for tethering with pppob')
options=('!libtool')
source=("https://github.com/NetDirect/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
- "barrydesktop.desktop"
"barrybackup.desktop"
"fix-sizeof-use.patch"
- "wx3.0-compat.patch"
"c++11.patch"
- "iterator-buildfix.patch"
"libusb-rules-noplugdev.patch")
sha256sums=('cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91'
- 'aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21'
'1c6ecd68977da4a3184c3e6d4bea36e4c40949d6bf7bb4ad8717aa6c19fed4fa'
'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
- 'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3'
'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c'
- '690d6d9cdd5f84ac120e5e2a0c974916217a059c25ad08dd1b45b33d858993ad'
'2da11475bb3d5c9c94f7625b33e3ae29442413b25f320e9f70d4777180d5bd4a')
prepare() {
@@ -36,14 +30,10 @@ prepare() {
# Debian patches
patch -Np1 -i "${srcdir}/fix-sizeof-use.patch"
- patch -Np1 -i "${srcdir}/wx3.0-compat.patch"
# C++11 compatibility
patch -Np1 -i "${srcdir}/c++11.patch"
- # Fix build failure for functions that return reverse iterators
- patch -Np1 -i "${srcdir}/iterator-buildfix.patch"
-
# Don't set device group ownership to plugdev in the udev rules file as Arch
# doesn't have plugdev. Just apply read-write globally
patch -Np1 -i "${srcdir}/libusb-rules-noplugdev.patch"
@@ -57,10 +47,7 @@ build() {
export CXXFLAGS="-std=c++11"
export CPPFLAGS="-Wno-error"
- ./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin \
- --enable-gui \
- --disable-desktop \
- --without-guisu
+ ./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin --enable-gui
make
}
@@ -80,9 +67,6 @@ package() {
cp ./desktop/images/barry_logo_icon.xpm ${pkgdir}/usr/share/pixmaps
mkdir -p ${pkgdir}/usr/share/applications
- # We are no longer compiling barrydesktop so there's no need to install the
- # desktop entry file
- # cp ../barrydesktop.desktop ${pkgdir}/usr/share/applications
cp ../barrybackup.desktop ${pkgdir}/usr/share/applications
# Install udev rules to allow barrybackup to access devices without root