summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e56ffb4a5281..651dc89cdbf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
# Category: science
pkgname='barvinok'
-pkgver='0.39'
+pkgver='0.40'
pkgrel=1
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
arch=('i686' 'x86_64')
url='http://freecode.com/projects/barvinok'
license=('GPL')
-depends=('ntl' 'isl' 'polylib-gmp' 'glpk>4.47')
+depends=('ntl' 'isl' 'polylib-gmp')
source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('d0b6165c4e92b253369f92e6e0be23ef')
+md5sums=('a5c0b48b4e336ee652e6e517d14ea9b6')
build() {
cd "$srcdir/$pkgname-$pkgver"
- env CPPFLAGS="-DNTL_STD_CXX" ./configure --prefix=/usr --with-isl=system --with-polylib=system
+ ./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system
make
}
@@ -24,5 +24,5 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- make prefix="$pkgdir"/usr install
+ make DESTDIR="$pkgdir" install
}