summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 651dc89cdbf0..18afe8bf5847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
-# Category: science
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
pkgname='barvinok'
-pkgver='0.40'
-pkgrel=1
+pkgver=0.40
+pkgrel=2
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://freecode.com/projects/barvinok'
license=('GPL')
depends=('ntl' 'isl' 'polylib-gmp')
@@ -13,7 +12,9 @@ md5sums=('a5c0b48b4e336ee652e6e517d14ea9b6')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system
+
+ # NTL 11 now uses pthread functions, so we need to have it link to libpthread.
+ ./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system LIBS="-lpthread"
make
}