summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94218fd92cd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brokenpip3 <brokenpip3[at]gmail[dot]com>
+
+pkgname=bash-bats-detik
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A library to ease e2e tests of applications in K8s environments with bats"
+arch=("any")
+url="https://github.com/bats-core/bats-detik"
+license=("MIT")
+depends=('bash-bats')
+source=("https://github.com/bats-core/bats-detik/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('c2b5414ff1d52655a4aefe266dc96be23591fbcfed288d16ec656fb0bedcd8c4da370767000b5c59faba1c34dea0c2767ec2684cb48d0d220a50472e23a0019f')
+
+check() {
+ cd "${srcdir}/bats-detik-${pkgver}"
+ bats tests
+}
+
+package() {
+ cd "${srcdir}/bats-detik-${pkgver}"
+
+ for fn in lib/*.bash; do
+ install -Dm755 ${fn} "${pkgdir}/usr/lib/bats-detik/$(basename $fn)"
+ done
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}