summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98aba91a5928..5d33323ae402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Quentin Bouvet <qbouvet at outlook dot com>
pkgname=bash-timer
-pkgver=v1.1.0.r0.g35040fb
+pkgver=1.1.0
pkgrel=1
pkgdesc="Human-readable execution time for every command in bash!"
arch=('any')
url="https://github.com/hopeseekr/bash-timer"
license=('APACHE')
-
depends=('bash-preexec-git')
-#makedepends=()
-source=("$pkgname::git+https://github.com/hopeseekr/bash-timer.git")
-install=$pkgname.install
-md5sums=('SKIP')
-pkgver() {
- cd "$srcdir/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("${pkgname}-${pkgver}::https://github.com/hopeseekr/bash-timer/archive/v${pkgver}.tar.gz")
+install=${pkgname}.install
+sha256sums=('75e16d41893074c2f57cb2c8dff1e04c8dc74dd8f43ee3917f9a48982d040753')
package() {
- cd "$srcdir/$pkgname"
- install -D -m0755 "$srcdir/$pkgname/bash-timer.sh" "$pkgdir/usr/share/bash-timer/bash-timer.sh"
+ cd "${srcdir}/"
+ install -D -m0755 -t "${pkgdir}/usr/share/${pkgname}" \
+ "${pkgname}-${pkgver}/${pkgname}.sh"
}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#