summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faaa4b554aad..572d1fb27692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: n0vember <n0vember at half-9 dot net>
pkgname=bash_unit
-pkgver=114.7732279
+pkgver=1.0.0
pkgrel=1
pkgdesc="bash unit testing enterprise edition framework for professionals"
arch=('any')
@@ -10,18 +10,18 @@ depends=('bash')
source=(git+https://github.com/pgrange/bash_unit.git)
md5sums=('SKIP')
-pkgver() {
- cd "$pkgname"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
build() {
- true
+ cd "$pkgname"
+ git checkout tags/v$pkgver -b v$pkgver
}
package() {
cd "$pkgname"
install -Dm755 -o root -g root bash_unit "$pkgdir/usr/bin/bash_unit"
+
+# TODO uncomment this and update pkgver when man is accessible through a release
+# install -dm755 ${pkgdir}/usr/share/man/man1
+# cp -dpr --no-preserve=ownership docs/man/man1/*.1 "$pkgdir/usr/share/man/man1"
}