summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43f9ca7ab2a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor <victor@xirion.net>
+pkgname=batify-git
+_pkgname=batify
+_xpub=xpub
+pkgver=1.0.r15.g691dc5b
+pkgrel=1
+pkgdesc='One udevrules file triggering plug and battery level notifications (multi-X sessions support).'
+arch=('any')
+url="https://github.com/Ventto/${_pkgname}.git"
+license=('MIT')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=('libnotify' 'xpub')
+optdepends=('notification-daemon')
+source=("git+https://github.com/Ventto/${_pkgname}.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 99-${_pkgname}.rules ${pkgdir}/etc/udev/rules.d/99-${_pkgname}.rules
+}