summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f48ce53a786d..cae02928973c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@
pkgbase=bcc-git
pkgname=('bcc-git' 'bcc-tools-git' 'python-bcc-git' 'python2-bcc-git')
pkgver=v0.1.7.r88.f50ca1f
-pkgrel=1
+pkgrel=2
pkgdesc="BPF Compiler Collection - latest git code"
arch=('x86_64')
url="https://github.com/iovisor/bcc"
license=('Apache')
-provides=('bcc')
conflicts=('bcc')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python'
'python2')
@@ -38,8 +37,8 @@ build() {
package_bcc-git() {
pkgdesc="BPF Compiler Collection - C library and examples"
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
- provides=('bcc' 'libbcc')
- conflicts=('bcc' 'libbcc')
+ provides=('bcc-git' 'libbcc-git')
+ conflicts=('bcc')
optdepends=('bcc-tools-git: Python utilites using the BCC library'
'python-bcc-git: Python 3 bindings for BCC'
'python2-bcc-git: Python 2 bindings for BCC')
@@ -58,7 +57,6 @@ package_bcc-git() {
package_bcc-tools-git() {
pkgdesc="BPF Compiler Collection - Tools"
depends=('bcc-git')
- provides=('bcc-tools')
conflicts=('bcc-tools')
optdepends=('python-bcc-git: Python 3 bindings for BCC'
'python2-bcc-git: Python 2 bindings for BCC')
@@ -75,7 +73,6 @@ package_python-bcc-git() {
pkgdesc="BPF Compiler Collection - Python 3 bindings"
makedepends=('cmake')
depends=('bcc-git' 'python')
- provides=('python-bcc')
conflicts=('python-bcc')
# the C lib s already built, force a quick python3 binding build
@@ -94,7 +91,6 @@ package_python2-bcc-git() {
pkgdesc="BPF Compiler Collection - Python 2 bindings"
makedepends=('cmake')
depends=('bcc-git' 'python2')
- provides=('python2-bcc')
conflicts=('python2-bcc')
# the C lib is already built, force a quick python2 binding build