summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7dacef46bcad..a517a1a3478c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Maintainer: Andrew O'Neill <andrew at haunted dot sh>
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=bcftools
-pkgver=1.8
+pkgver=1.20
pkgrel=1
-pkgdesc="A program for variant calling and manipulating files in the Variant Call Format (VCF) and its binary counterpart BCF"
-arch=('i686' 'x86_64')
-url="http://samtools.github.io/bcftools/"
-license=('GPL')
+pkgdesc='A program for variant calling and manipulating files in the Variant Call Format (VCF) and its binary counterpart BCF'
+arch=('x86_64')
+url='https://samtools.github.io/bcftools'
+license=('GPL-3.0-only')
depends=('gsl' 'htslib' 'python-matplotlib' 'python')
-source=(https://github.com/samtools/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('4acbfd691f137742e0be63d09f516434f0faf617a5c60f466140e0677915fced')
+source=("https://github.com/samtools/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('312b8329de5130dd3a37678c712951e61e5771557c7129a70a327a300fda8620')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--enable-libgsl \
- --with-bcf-plugin-dir=/usr/lib/$pkgname \
+ --with-bcf-plugin-dir=/usr/lib/${pkgname} \
--with-cblas=gslcblas \
--with-htslib=system
@@ -26,7 +26,7 @@ build() {
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- make DESTDIR=$pkgdir install
+ make DESTDIR="${pkgdir}" install
}