summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b311bcd3714..bb2e905bb39d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=bcftools
-pkgver=1.4.1
+pkgver=1.5
pkgrel=1
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
@@ -9,8 +9,7 @@ url="http://samtools.github.io/bcftools/"
license=('GPL')
depends=('gsl' 'htslib')
optdepends=('python2: needed for some scripts')
-source=(https://github.com/samtools/bcftools/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
- makefile-system-htslib.patch)
+source=(https://github.com/samtools/bcftools/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2)
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -21,28 +20,31 @@ prepare() {
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
-e 's|#!/usr/bin/python|#!/usr/bin/env python2|' \
-i misc/plot-roh.py misc/guess-ploidy.py
-
- # patch Makefile to make it work with a system-provided htslib
- patch -i $srcdir/makefile-system-htslib.patch
}
build() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1
+ ./configure \
+ --prefix=/usr \
+ --enable-libgsl \
+ --with-bcf-plugin-dir=/usr/lib/$pkgname \
+ --with-cblas=gslcblas \
+ --with-htslib=system
+
+ make
}
check() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 test
+ make check
}
package() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 DESTDIR=$pkgdir install
+ make DESTDIR=$pkgdir install
}
-md5sums=('103729569ca3e265b13d2fed5775016e'
- '1777e7d3bcfd428de407f62c870904cb')
+md5sums=('e43efe3df5f9c55acb4b48cee214d281')