summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7c088092ef2..f879c2dc8691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=bcftools
-pkgver=1.3
-pkgrel=3
+pkgver=1.3.1
+pkgrel=1
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
url="http://samtools.github.io/bcftools/"
license=('GPL')
-depends=('gsl' 'htslib' 'perl')
+depends=('gsl' 'htslib')
source=(https://github.com/samtools/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
- https://github.com/pd3/bcftools/commit/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
makefile-system-htslib.patch)
-md5sums=('17f1f7d9e4a03d64a114b43ca896899f'
- 'dd48ce1ac8ef91ea409f8f235574de2e'
- 'e5145d175dcd242634baf42749b838f0')
+md5sums=('575001e9fca37cab0c7a7287ad4b1cdb'
+ '3547e133251f4d088cb087019183efa7')
prepare() {
cd $srcdir/$pkgname-$pkgver
# prevent shipped htslib to be used
- rm -rf htslib-1.3
+ rm -rf htslib-1.3.1
# patch Makefile to make it work with a system-provided htslib
patch -i $srcdir/makefile-system-htslib.patch
-
- # patch gsl >= 2 problem
- patch -i $srcdir/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
}
build() {