summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cb4bbc95551..710096a3a998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=5.3.0.alpha.r10.gb0027df
+pkgver=5.3.0.alpha.r40.g6a403ee
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
arch=('x86_64')
@@ -10,23 +10,23 @@ url="http://www.linphone.org/"
license=('GPL')
conflicts=('bctoolbox')
provides=('bctoolbox=$pkgver')
-depends=('bcunit>=3.0.2+12' 'libdecaf' 'mbedtls')
+depends=('libdecaf' 'mbedtls')
makedepends=('cmake' 'git')
source=("git+https://github.com/BelledonneCommunications/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cmake -B build "${_pkgname}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC="NO" \
- -DENABLE_TESTS="YES" \
- -DENABLE_TESTS_COMPONENT="YES" \
+ -DENABLE_TESTS_COMPONENT="NO" \
-DCMAKE_C_FLAGS="${CFLAGS} -Wno-error=unused-parameter" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DBUILD_SHARED_LIBS=YES \
-Wno-dev
make -C build
}