summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41c14bc491bb..5722ece0a180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=0.6.0.r150.g94b50fe
+pkgver=0.6.0.r170.g25f4a51
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
arch=('x86_64')
@@ -10,7 +10,7 @@ url="http://www.linphone.org/"
license=('GPL')
conflicts=('bctoolbox')
provides=('bctoolbox')
-depends=('libdecaf' 'mbedtls')
+depends=('bcunit-git' 'libdecaf' 'mbedtls')
makedepends=('cmake' 'git')
source=("git+https://github.com/BelledonneCommunications/$_pkgname.git")
sha256sums=('SKIP')
@@ -25,8 +25,10 @@ build() {
cd build
cmake -DENABLE_TESTS_COMPONENT=NO \
-DCMAKE_INSTALL_LIBDIR="/usr/lib" \
- -DCMAKE_INSTALL_PREFIX="/usr" "../$_pkgname" \
- -DENABLE_STATIC="NO"
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC="NO" \
+ -DENABLE_TESTS="YES" \
+ -DENABLE_TESTS_COMPONENT="YES" ../"${_pkgname}"
make
}