summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 30 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e3b1e803883..f0f0341dc7c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
-# Maintainer: ny-a <nyaarch64@gmail..com>
-# Contributor: Jean Lucas <jean@4ray.co>
+# Maintainer: Matej Dujava <mdujava (plus) aur (at) kocurkovo (dot) cz>
-pkgname=beaker
-pkgver=1.1.0
+pkgname=('beaker-common' 'beaker-client')
+pkgbase='beaker'
+pkgver=28.2
pkgrel=1
-pkgdesc='Experimental peer-to-peer web browser'
-arch=(i686 x86_64)
-url=https://beakerbrowser.com
-license=(MIT)
-depends=(alsa-lib atk at-spi2-atk cairo gcc-libs gdk-pixbuf2 glibc gtk3 libcups libsodium libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nodejs nspr nss pango python)
-makedepends=(npm git python2)
-source=(beaker-$pkgver.tar.gz::https://github.com/beakerbrowser/beaker/archive/$pkgver.tar.gz
- beaker.desktop)
-sha512sums=('39126782e1b81a39902b78b9bd9b7bc7a6c955e540f94cd7e59da0d46286e74cab9f5d43f96e48b2428538d7eae30146193b1999adbcca16d1021879c7177ff3'
- '24210bb1900112d4b4ff37ed7e57055516b4134d277730bf78e69e7c30c2f2655fb21f5266719a60b3edd2dfea7c8ec9e0d56d71f9a9daf1b674f9108831df08')
+pkgdesc="Full-stack software and hardware integration testing system"
+arch=('any')
+url="https://beaker-project.org/"
+license=('GPL' 'BSD')
+makedepends=('python-nose' 'python-mock' 'python-docutils' 'python-sphinx' 'make' 'python-gssapi' 'python-lxml' 'python-prettytable' 'python-lxml')
+provides=('bkr' 'beaker-wizard')
+options=('zipman')
+source=("beaker-$pkgver.tar.gz::https://github.com/beaker-project/beaker/archive/refs/tags/beaker-$pkgver.tar.gz")
+sha256sums=('5aa4c1807187e7c318db1ddc9132d1045824f6eaa6f04773663d9fae0e950b8c')
build() {
- cd beaker-$pkgver/scripts
- npm i
- npm run build
- npm run rebuild
- npx electron-builder --dir
+ export BKR_PY3="$(which python3)"
+ cd "$pkgbase-$pkgbase-$pkgver"
+ make
}
-package() {
- install -Dm 644 beaker.desktop -t "$pkgdir"/usr/share/applications
+package_beaker-common() {
+ pkgdesc="Full-stack software and hardware integration testing system - common files"
- cd beaker-$pkgver
+ export BKR_PY3="$(which python3)"
+ cd "$pkgbase-$pkgbase-$pkgver"
+ make DESTDIR="$pkgdir/" -C Common install
+}
- mkdir "$pkgdir"/usr/{lib,bin}
- cp -a dist/linux-unpacked "$pkgdir"/usr/lib/beaker
- ln -s /usr/lib/beaker/beaker-browser "$pkgdir"/usr/bin/beaker
+package_beaker-client() {
+ pkgdesc="Full-stack software and hardware integration testing system - cli"
+ depends=('python' 'python-six' 'python-setuptools' 'python-gssapi' 'python-lxml' 'python-requests' 'python-prettytable' 'python-jinja' "beaker-common=$pkgver")
- for i in 16 24 32 48 64 96 128 256 512 1024; do
- install -Dm 644 build/icons/${i}x${i}.png \
- "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/beaker.png
- done
+ export BKR_PY3="$(which python3)"
+ cd "$pkgbase-$pkgbase-$pkgver"
+ make DESTDIR="$pkgdir/" -C Client install
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/beaker
+ install -Dm 755 -d "$pkgdir/usr/share/man/man1"
+ install -m 644 -t "$pkgdir/usr/share/man/man1" documentation/_build/man/*
}