summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 920b7c31adff..271e92929b39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bearssl
pkgver=0.6
-pkgrel=3
+pkgrel=4
pkgdesc='Implementation of the SSL/TLS protocol (RFC 5246) written in C'
arch=('i486' 'i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://bearssl.org'
@@ -26,14 +26,15 @@ check() {
}
package() {
- mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/lib" "${pkgdir}/usr/share/licenses/${pkgname}" # "${pkgdir}/usr/include/${pkgname}"
+ mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/include" "${pkgdir}/usr/lib" "${pkgdir}/usr/share/licenses/${pkgname}"
cd "./${pkgname}-${pkgver}/build"
# ideally, we should encapsulate headers in a namespace, but not now
#sed -i 's|"bearssl_|"bearssl/|g' ../inc/*
+ #mkdir "${pkgdir}/usr/include/${pkgname}"
cp '../inc/bearssl.h' "${pkgdir}/usr/include"
for h in ../inc/*; do
- cp "$h" "${pkgdir}/usr/include" # "${pkgdir}/usr/include/bearssl/${h#*_}"
+ cp "$h" "${pkgdir}/usr/include" # "${pkgdir}/usr/include/${pkgname}/${h#*_}"
done
cp '../LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}"