summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c420d83fcdfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Jean-Baptiste Delisle <jb dot delisle at aliceadsl dot fr>
+pkgname=bed-latex-git
+pkgver=git
+pkgrel=1
+pkgdesc="BEd: Beamer Editor, GUI for LaTeX Beamer presentations."
+arch=(any)
+url="https://framagit.org/delisle/bed"
+license=('GPL3')
+depends=('python>=3.0' 'python-pyqt5' 'python-poppler-qt5' 'texlive-core' 'texlive-latexextra')
+optdepends=('python-pygments')
+makedepends=()
+provides=('bed-latex')
+conflicts=('bed','bed-latex')
+install="bed.install"
+source=("$pkgname::git+https://framagit.org/delisle/bed.git")
+md5sums=('SKIP')
+
+
+prepare() {
+ cd $pkgname
+ sed -i -e "s#/tmp/python3#/usr/bin/python3#" python/bed.py
+ sed -i -e "s#/tmp/pdflatex#pdflatex#" python/settings.py
+ sed -i 's#/local##g' launcher/bed.desktop
+}
+
+package(){
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/bed
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/bed
+ mkdir -p $pkgdir/usr/share/applications
+ mkdir -p $pkgdir/usr/share/pixmaps
+
+ cd $pkgname
+ cp python/*.py $pkgdir/usr/share/bed
+ chmod +x $pkgdir/usr/share/bed/bed.py
+ cp icons/* $pkgdir/usr/share/bed
+ cp translation/*.qm $pkgdir/usr/share/bed
+ cp launcher/bed.desktop $pkgdir/usr/share/applications/
+ cp latex/bed.sty $pkgdir/usr/share/texmf/tex/latex/bed/
+ cd $pkgdir/usr/bin/
+ ln -s ../share/bed/bed.py bed
+ cd $pkgdir/usr/share/pixmaps
+ ln -s ../bed/bed.svg bed.svg
+}