summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b0f303cd353..5d8983833115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# Maintainer: Amiad Bareli <amiadb at gmail dot com>
-# Last Contributor: amiad
pkgname=behafucha
-pkgver=0.7
-pkgrel=6
+pkgver=0.8
+pkgrel=2
pkgdesc="Convert English/Hebrew text to Hebrew/English text"
-arch=('i686' 'x86_64')
-url="https://github.com/ilsh1964/behafucha/"
+arch=('any')
+url="https://github.com/amiad/behafucha/"
license=('GPL')
-depends=(bc zenity pygtk xsel xvkbd)
-source=(https://github.com/ilsh1964/$pkgname/archive/v$pkgver.tar.gz)
-sha256sums=('75d3598b0dc64ec17ddd8c6216e0c33c3922cef2f07259a0c95db026556ae20f')
+depends=(python xsel xvkbd)
+source=(https://github.com/amiad/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('a48037533a499100b38ea3c0b9db73cf2dab7c091baeae4222b053ae4c4b6bf5')
-build() {
+package() {
cd $srcdir/Behafucha-$pkgver/Source/
- sed -i '1c#!/usr/bin/python2' Behafucha.py
- sed -i '3c python2 /usr/lib/Behafucha/Behafucha.py' $pkgname
install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
install -Dm 644 Behafucha.py $pkgdir/usr/lib/Behafucha/Behafucha.py
install -Dm 644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
install -Dm 644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
}
-