summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 22 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a1c3f3f895c..45161ee6f8bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,30 @@
-# Original Maintainer: Antoine Lubineau <antoine@lubignon.info>
-# Current Maintainer: Leopold Bloom <blinxwang@gmail.com>
+# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani@gmail.com>
+# Contributor: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Leopold Bloom <blinxwang@gmail.com>
+# Contributor: Michal Krenek (a.k.a. Mikos) <m.krenek@gmail.com>
+
pkgname=beignet
-pkgver=1.1.2
-pkgrel=5
+pkgver=1.2.0
+pkgrel=1
pkgdesc='A GPGPU System for Intel Ivybridge GPUs'
arch=('x86_64')
-url='http://cgit.freedesktop.org/beignet/'
+url="https://01.org/beignet"
license=('LGPL2.1')
-depends=('glu' 'libsm' 'libxext' 'mesa' 'ncurses' 'ocl-icd' 'opencl-headers' 'llvm')
+depends=('glu' 'llvm' 'mesa' 'ocl-icd')
makedepends=('clang' 'cmake' 'python2')
-provides=('opencl-intel')
-conflicts=('opencl-intel')
-source=("https://01.org/sites/default/files/beignet-$pkgver-source.tar.gz"
- "isnan.patch"
- "gcc6.patch"
- "clangfix.patch")
-sha256sums=('6a8d875afbb5e3c4fc57da1ea80f79abadd9136bfd87ab1f83c02784659f1d96'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-prepare() {
- cp isnan.patch "$srcdir/Beignet-$pkgver-Source"
- cp gcc6.patch "$srcdir/Beignet-$pkgver-Source"
- cp clangfix.patch "$srcdir/Beignet-$pkgver-Source"
- cd "$srcdir/Beignet-$pkgver-Source"
- patch -Np1 -i isnan.patch
- patch -Np1 -i gcc6.patch
- patch -Np1 -i clangfix.patch
- cd "include/CL"
- rm {opencl.h,cl_platform.h,cl_gl_ext.h,cl.h,cl.hpp,cl_egl.h,cl_ext.h,cl_gl.h}
- touch dummy.hpp
-}
+provides=('opencl-intel' 'opencl-headers' 'opencl-headers12')
+conflicts=('opencl-intel' 'opencl-headers' 'opencl-headers12')
+source=("https://01.org/sites/default/files/beignet-${pkgver}-source.tar.gz")
+sha256sums=('fc7af19efb7596b04510d26c558a576eba3e95e1ef86fd6951213c6a4bf58bff')
+
+#prepare() {
+# cd "${srcdir}/Beignet-${pkgver}-Source/include/CL"
+# rm cl.h cl.hpp cl_d3d10.h cl_d3d11.h cl_dx9_media_sharing.h cl_egl.h cl_ext.h cl_gl.h cl_gl_ext.h cl_platform.h opencl.h
+#}
build() {
- mkdir -p "$srcdir/Beignet-$pkgver-Source/build"
- cd "$srcdir/Beignet-$pkgver-Source/build"
+ mkdir -p "${srcdir}/Beignet-${pkgver}-Source/build"
+ cd "${srcdir}/Beignet-${pkgver}-Source/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
@@ -44,6 +34,6 @@ build() {
}
package() {
- cd "$srcdir/Beignet-$pkgver-Source/build"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/Beignet-${pkgver}-Source/build"
+ make DESTDIR="${pkgdir}/" install
}