summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2557d31da2f7..5d0911e616e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=benchmark
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A microbenchmark support library, by Google"
arch=('any')
url="https://github.com/google/benchmark"
license=('Apache')
depends=('gcc-libs')
-makedepends=('cmake' 'gtest' 'gmock')
+makedepends=('cmake')
source=("https://github.com/google/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('f8e525db3c42efc9c7f3bc5176a8fa893a9a9920bbd08cef30fb56a51854d60d')
@@ -18,13 +18,12 @@ prepare() {
mkdir -p build && cd build
- # For now, disable BENCHMARK_ENABLE_LTO, as it causes
- # more tests to fail and also breaks on GCC 9
- # (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85583)
cmake .. -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=ON \
+ -DBENCHMARK_ENABLE_LTO=ON \
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
}
build() {
@@ -32,11 +31,6 @@ build() {
make
}
-check() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
- make test || echo "Ignore for now, as the test is expected to fail: https://github.com/google/benchmark/issues/578"
-}
-
package() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="$pkgdir/" install