summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c57621fa791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Debucquoy Anthony (tonitch) <d.tonitch@gmail.com>
+pkgname=better-commits
+pkgver=1.7.2
+pkgrel=1
+pkgdesc="A CLI for creating better commits following the conventional commit guidelines."
+arch=(any)
+url="https://github.com/Everduin94/better-commits"
+license=('MIT')
+makedepends=('npm')
+source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
+noextract=("${pkgname}-${pkgver}.tgz")
+sha256sums=('80721b65c4912dd96c1140f8d6932ca86725f3d9a1d286f912cffa119739ad87')
+
+package() {
+ npm install -g --cache "${srcdir}/npm-cache" --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+}