summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fd86728286f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: TheCynicalTeam <TheCynicalTeam@github.com>
+# Contributor: TheCynicalTeam <TheCynicalTeam@github.com>
+
+pkgname=bfetch
+pkgver=2021.01.18
+pkgrel=1
+pkgdesc="A CLI system information tool written in BASH that supports displaying images."
+arch=('any')
+url="https://github.com/TheCynicalTeam/$pkgname"
+license=('CC BY-NC-SA 4.0')
+depends=('bash')
+makedepends=('git')
+optdepends=(
+ 'catimg: Display Images'
+ 'chafa: Image to text support'
+ 'feh: Wallpaper Display'
+ 'imagemagick: Image cropping / Thumbnail creation / Take a screenshot'
+ 'jp2a: Display Images'
+ 'libcaca: Display Images'
+ 'nitrogen: Wallpaper Display'
+ 'w3m: Display Images'
+ 'xorg-xdpyinfo: Resolution detection (Single Monitor)'
+ 'xorg-xprop: Desktop Environment and Window Manager'
+ 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
+)
+source=("${pkgname}-$pkgver.tar.gz::${url}/archive/$pkgver.tar.gz")
+sha256sums=('0f247c19fe038322e2905a7bbfa1e28ced37bbbbc6a7776a19a6c74333352ac4')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}