summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f508a96bab7..5bf9464d23f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,38 @@
# Maintainer: Shatur95 <genaloner@gmail.com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: ful1e5 <kaizmandhu at gmail dot com>
pkgname=bibata-cursor-theme
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Material Based Cursor Theme"
arch=('any')
url="https://github.com/ful1e5/Bibata_Cursor"
license=('GPL3')
-makedepends=('python-clickgen' 'yarn' 'npm' 'alsa-lib' 'gtk3' 'libcups'
- 'libxss' 'libxtst' 'nss')
+makedepends=('python-clickgen')
options=('!strip')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('5e694dafa6d0a338bb744d43d09b0d31fc55f105b3659754ea226d170b590999')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$url/releases/download/v$pkgver/bitmaps.zip")
+noextract=('bitmaps.zip')
+sha256sums=('5e694dafa6d0a338bb744d43d09b0d31fc55f105b3659754ea226d170b590999'
+ '629f7a5042d704c6aa5518e4327ef62e20528625354aaf459eda75765a0a7fa8')
+
+prepare() {
+ cd Bibata_Cursor-$pkgver
+ mkdir -p bitmaps
+ bsdtar -xvf "$srcdir"/bitmaps.zip -C bitmaps
+
+ rm -rf themes
+}
build() {
- cd "$srcdir/Bibata_Cursor-$pkgver"
- yarn install --cache-folder "$srcdir/yarn-cache"
- yarn render:bibata-modern
- yarn render:bibata-original
- yarn build
+ cd Bibata_Cursor-$pkgver
+ python build.py
}
package() {
- cd "$srcdir/Bibata_Cursor-$pkgver"
- install -d "$pkgdir/usr/share/icons"
- cp -r themes/Bibata-* "$pkgdir/usr/share/icons"
+ cd Bibata_Cursor-$pkgver
+ install -d "$pkgdir"/usr/share/icons
+ cp -r themes/Bibata-* "$pkgdir"/usr/share/icons
chmod -R 755 "$pkgdir"/usr/share/icons/Bibata-*
}