summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fe3f97c2f24..9a20db9278a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,20 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bibstuff
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
url="http://dschwilk.github.io/bibstuff"
arch=('any')
license=('MIT')
-depends=('python2')
+depends=('python2-simpleparse')
source=(bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip)
md5sums=('4d89e8356f99456adae34aeede5af79b')
+prepare() {
+ cd $srcdir/$pkgname-master
+ find . -name "*.py" -exec sed -i '1s+python+python2+' {} \;
+}
+
package() {
cd $srcdir/$pkgname-master
python2 setup.py install --root=$pkgdir
@@ -24,5 +29,4 @@ package() {
# copying examples directory
install -d $pkgdir/usr/share/doc/$pkgname/examples
cp examples/* $pkgdir/usr/share/doc/$pkgname/examples
- sed -i '1s+python+python2+' $pkgdir/usr/share/doc/bibstuff/examples/jmaker.py
}