summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6382ca9f0c50..8e2e2b34f7a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,23 @@
pkgname=bigloo-devel
pkgver=4.5b
-pkgrel=5
+pkgrel=6
epoch=1
_suffix=unstable
pkgdesc="Fast scheme compiler"
arch=('x86_64')
url="https://www-sop.inria.fr/mimosa/fp/Bigloo/"
license=('GPL' 'LGPL')
-depends=('gmp' 'openssl' 'libunistring' 'libnsl' 'gc' 'libuv' 'libpulse' 'mpg123' 'avahi' 'sqlite' 'gstreamer')
-makedepends=('java-environment' 'emacs' 'zip' 'sqlite' 'alsa-lib' 'flac' 'avahi' 'chrpath' 'tar')
-optdepends=('java-environment' 'emacs' 'zip' 'sqlite' 'alsa-lib' 'flac' 'avahi')
+depends=('gmp' 'openssl' 'libunistring' 'libnsl' 'gc' 'libuv'
+ 'libpulse' 'mpg123' 'avahi' 'sqlite' 'gstreamer')
+makedepends=('java-environment' 'emacs' 'zip' 'sqlite' 'alsa-lib'
+ 'flac' 'avahi' 'chrpath' 'tar')
+optdepends=('emacs' 'zip' 'sqlite' 'alsa-lib' 'flac' 'avahi')
options=('!makeflags' 'staticlibs')
conflicts=('bigloo')
provides=("bigloo=$pkgver")
source=(ftp://ftp-sop.inria.fr/indes/fp/Bigloo/${pkgname%-devel}-${_suffix}.tar.gz bigloo-emacs.patch)
-sha256sums=('05511c27e147985898c30f3784e454c96dc78f179aa08236bacd4db3fdcc3697'
+sha256sums=('8c317e2c505776137727ce92dde3445e9541d75234ed1800de7f196264440dfd'
'80356c27b58a302775f75e848a89ab2d588796a548f4ce7a20df048e215deab0')
prepare() {
@@ -46,8 +48,10 @@ build() {
--enable-sqlite \
--enable-ssl \
--enable-gstreamer \
- --disable-mqtt
-
+ --bee=full \
+ --disable-mqtt \
+ --no-ldpreload
+
EXTRALIBS="-ldl -lresolv -lunistring -lpcre -lgmp -lm -lc" make build compile-bee
}