summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b00613d24833..f0c3c09b5691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Yufan You <ouuansteve at gmail>
pkgname=bilili
-pkgver=1.4.12
+pkgver=1.4.15
pkgrel=1
pkgdesc='bilibili video and danmaku downloader | B站视频、弹幕下载器'
arch=('any')
-url='https://github.com/SigureMo/bilili'
+url='https://github.com/yutto-dev/bilili'
license=('GPL3')
depends=('python-requests' 'python-biliass' 'ffmpeg')
-makedepends=('python-setuptools' 'python-wheel')
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://pypi.io/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('93631af491a80ae5f6a15a7d31a5d6d8e522ea17629ea4f2704bedce98a3767a')
+sha256sums=('902210cc3ac259af0d1b215fa9a16b059a62ee423b72985eb563b66e2b2800c1')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- rm -rf "$pkgdir/usr/lib/"*"/site-packages/tests" || true
+ python -m installer --destdir="$pkgdir" dist/*.whl
}