summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7034b8475ca..d60bdf9c0ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=bino
-pkgver=1.6.6
+pkgver=1.6.7
pkgrel=1
pkgdesc='3D video player with multi-display support'
arch=('i686' 'x86_64')
@@ -11,24 +11,26 @@ url='https://bino3d.org/'
license=('GPL3')
depends=('ffmpeg' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
optdepends=('lirc: infrared remote control')
-source=(https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
- 'gui_common.h')
-sha512sums=('43a17f390881fcc8b7721b21ff8524b89992cd7fb0cfc467769bdddd0ad0c0d2536d161475a7fce6d4d3e758e017a38f671648dfaa4a345dc02127b7b192c8c0'
- 'SKIP'
- '8006b07a72f964da78a9ba3df7c4ead522cdca0303ab1c1d9b8224a6dd062f24e0bccf95146656e28c5ba3baa8dbc2e513309adb7486e26f1d3563eec35d0325')
+source=(https://bino3d.org/releases/bino-1.6.7.tar.xz{,.sig})
+sha512sums=('ae8f72b200100664b9fd55963371ce64a2f39e240676494d69b422d662f2295560ba458eb04707b82f88d3c6b3fab98a1ecb40d74799300f96b8eb8be680c9b8'
+ 'SKIP')
validpgpkeys=('2F61B4828BBA779AECB3F32703A2A4AB1E32FD34')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i 's/CXXFLAGS -fPIE/& -fPIC/' configure
- ./configure --prefix=/usr \
- --with-qt-version=5 \
- #--with-xnvctrl # Enable NVIDIA Quadro SDI output
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- cp '../gui_common.h' 'src'
+ # libglewmx* env variables are to fix compilation issue
+ # when both glew and glew1.6 are installed
+ # details at https://gitlab.marlam.de/marlam/bino/issues/1
+ libglewmx_CFLAGS="$(pkg-config --cflags glew)" libglewmx_LIBS="$(pkg-config --libs glew)" ./configure \
+ --prefix=/usr \
+ --with-qt-version=5 \
+ #--with-xnvctrl # Enable NVIDIA Quadro SDI output
+ sed -i '/am__append_.* = -DGLEW_MX/d' src/Makefile
make
}