summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87222133dc28..4f271197b187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Ivo Nunes <ivoavnunes at gmail dot com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor : Ivo Nunes <ivoavnunes at gmail dot com>
_pkgname="birdie"
pkgname="${_pkgname}-git"
-pkgver=497+g345d84b
-pkgrel=6
+pkgver=1.1+git.21.gf235c55
+pkgrel=1
pkgdesc="Twitter client for Linux"
arch=('i686' 'x86_64')
url="http://birdieapp.github.io"
license=('GPL3')
-depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests' 'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow' 'gtksourceview3' 'webkitgtk' 'python2-socksipy-git')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests' 'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow' 'gtksourceview3' 'webkitgtk' 'python2-socksipy-branch')
makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
options=('!libtool')
conflicts=('birdie' 'birdie-bzr')
@@ -18,14 +19,14 @@ md5sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- echo $(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
+ echo $(git describe --tags | sed s'/v\.//;s/-/./g')
}
build() {
cd "${_pkgname}"
export PYTHON=`which python2`
./autogen.sh --prefix=/usr
- make ${MAKEFLAGS}
+ make
}
package() {