summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13383cb95784..d055d38f8cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
pkgname=bisq
-pkgver=1.9.4
+pkgver=1.9.14
pkgrel=1
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('any')
url="https://bisq.network"
license=('AGPL3')
depends=('jdk11-openjdk')
-makedepends=('jdk11-openjdk')
+makedepends=('jdk11-openjdk' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bisq-network/bisq/archive/v${pkgver}.tar.gz"
"https://github.com/bisq-network/bisq/releases/download/v${pkgver}/bisq-${pkgver}.tar.gz.asc"
"bisq.desktop")
-sha256sums=('efd23836a581843664089eb8967b97d081ad167721ab37597310fceda06b092f'
+sha256sums=('e5c1a95a5a67798cbd38460d6fa7e0c753ff3c804091da0bd5917201df52fff8'
'SKIP'
'687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
-validpgpkeys=('CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B') # Christoph Atteneder
+validpgpkeys=('B493319106CC3D1F252E19CBF806F422E222AA02') # Alejandro GarcĂ­a
_binname=Bisq
conflicts=("bisq-bin" "bisq-git")
@@ -25,6 +25,8 @@ provides=("bisq")
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit
msg2 "Building bisq..."
+ sed -i '/vendor = JvmVendorSpec.AZUL/d' build-logic/commons/src/main/groovy/bisq.java-conventions.gradle
+ sed -i '/implementation = JvmImplementation.VENDOR_SPECIFIC/d' build-logic/commons/src/main/groovy/bisq.java-conventions.gradle
./gradlew clean :desktop:build -Dorg.gradle.java.home=/usr/lib/jvm/java-11-openjdk -x test
}