summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 127d2aa8fc32..0d4c359ee816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,18 @@ url="https://bisq.network"
license=('AGPL3')
depends=('java-runtime' 'bash')
makedepends=('git' 'git-lfs' 'maven' 'jdk11-openjdk' 'protobuf')
-source=("https://github.com/bisq-network/${pkgname}/archive/v${pkgver}.tar.gz"
- "bisq.desktop")
-sha256sums=('e94472226acd2c149baadc4d11e49895a248b537cb0710e1f6b3ebe5d865e479'
- '687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
+source=("bisq.desktop")
+sha256sums=('687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
_binname=Bisq
conflicts=("bisq-bin" "bisq-git")
provides=("bisq")
+prepare() {
+ rm -rf "${srcdir}/${pkgname}-${pkgver}"
+ git clone --depth=1 --branch=v${pkgver} https://github.com/bisq-network/bisq.git ${pkgname}-${pkgver}
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit
msg2 "Building bisq..."