summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8a083a62702..3cd1e73e01ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,44 @@
-# Maintainer: Felipe F. Tonello <eu@felipetonello.com>
+# Contributor: Felipe F. Tonello <eu@felipetonello.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# TODO: support Toast
pkgbase=bitbake
pkgname=('bitbake' 'bitbake-vim')
-pkgver=1.30
-pkgrel=6
-pkgdesc="Build tool executing tasks and managing metadata."
+pkgver=1.34
+pkgrel=1
+pkgdesc='Build tool executing tasks and managing metadata.'
arch=('any')
-url="http://openembedded.org"
+url='https://www.openembedded.org/wiki/Main_Page'
license=('GPL2')
-makedepends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-codegen')
-source=(https://github.com/openembedded/${pkgbase}/archive/${pkgver}.zip)
-md5sums=('76e61f7efbabb38caf5f3531e87a988f')
+makedepends=('git' 'python' 'python-django18' 'python-beautifulsoup4' 'python-codegen' 'python-pyinotify' 'python-progressbar')
+source=('git://git.openembedded.org/bitbake#commit=b4da94a')
+md5sums=('SKIP')
check() {
- cd ${srcdir}/${pkgbase}-${pkgver}/bin
- PYTHONPATH=`pwd`/../lib:`pwd`/../lib/bb python2 ./bitbake-selftest
+ cd ${pkgbase}/bin
+ PYTHONPATH="${srcdir}/${pkgbaes}/lib:${srcdir}/${pkgbase}/lib/bb" python ./bitbake-selftest
}
package_bitbake() {
- depends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-codegen')
+ depends=('python' 'python-django18' 'python-beautifulsoup4' 'python-codegen' 'python-pyinotify' 'python-progressbar')
install=bitbake.install
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${pkgbase}
- install -d ${pkgdir}/usr/bin
- install bin/bitbake* ${pkgdir}/usr/bin
+ install -d "${pkgdir}/usr/bin"
+ install bin/bitbake* "${pkgdir}/usr/bin"
- install -d ${pkgdir}/usr/lib/python2.7/site-packages
- cp -Ra lib/bb ${pkgdir}/usr/lib/python2.7/site-packages
- cp -Ra lib/prserv ${pkgdir}/usr/lib/python2.7/site-packages
+ install -d "${pkgdir}/usr/lib/python3.6/site-packages"
+ cp -Ra lib/bb "${pkgdir}/usr/lib/python3.6/site-packages"
+ cp -Ra lib/prserv "${pkgdir}/usr/lib/python3.6/site-packages"
- install -d ${pkgdir}/usr/share/man/man1
- install doc/bitbake.1 ${pkgdir}/usr/share/man/man1
+ install -d "${pkgdir}/usr/share/man/man1"
+ install doc/bitbake.1 "${pkgdir}/usr/share/man/man1"
}
package_bitbake-vim() {
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${pkgbase}
- install -d ${pkgdir}/usr/share
- cp -Ra contrib/vim ${pkgdir}/usr/share
+ install -d "${pkgdir}/usr/share"
+ cp -Ra contrib/vim "${pkgdir}/usr/share"
}