summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8216084e162f..2d8f3314018f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Josh Ellithorpe <quest@mac.com>
pkgname=bitcoin-abc-qt
-pkgver=0.28.11
+pkgver=0.28.12
pkgrel=0
pkgdesc="Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, bitcoin-seeder and bitcoin-qt"
arch=('i686' 'x86_64')
url="https://bitcoinabc.org"
depends=('boost-libs' 'libevent' 'desktop-file-utils' 'qt5-base' 'protobuf' 'openssl' 'miniupnpc' 'libnatpmp' 'zeromq' 'qrencode' 'jemalloc')
-makedepends=('cmake' 'ninja' 'boost' 'qt5-tools' 'python' 'help2man' 'xorg-server-xvfb')
+makedepends=('binutils' 'cmake' 'ninja' 'boost' 'qt5-tools' 'python' 'help2man' 'xorg-server-xvfb')
license=('MIT')
source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.conf
@@ -33,6 +33,7 @@ build() {
-DCLIENT_VERSION_IS_RELEASE=ON \
-DENABLE_REDUCE_EXPORTS=ON \
-DENABLE_STATIC_LIBSTDCXX=ON \
+ -DUSE_LINKER= \
-DCMAKE_INSTALL_PREFIX=$pkgdir/usr
ninja
@@ -101,7 +102,7 @@ package() {
"$pkgdir/usr/share/bash-completion/completions/$_compl"
done
}
-sha256sums=('312cf301842413ccf02fb3870c9b8476db7978278c5fe2490e08ea1c4350af1c'
+sha256sums=('df2465e6a9f7faa13023488ba01a21a3a6b45b02dcffbb18b1e6f15f72052a76'
'c30e5c7e0e97b001fdeac5f4510d5ebc0e0499ec086325e845db609a24f2e22f'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'f2fd9d8331238727333cf2412ba3759cb194a65b2060eff36808b24c06382104'