summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c637562977f..061ca113d991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Amy <amy at fluff dot tech>
-_distnum=3014
-_distname="dist-chrome-${_distnum}.zip"
-
pkgname=bitwarden-chromium
-pkgver=1.51.1
+pkgver=2023.9.2
pkgrel=1
pkgdesc='Bitwarden Chromium extension'
arch=('any')
-url='https://github.com/bitwarden/browser'
+url='https://github.com/bitwarden/clients'
license=('GPL3')
makedepends=('git' 'unzip')
optdepends=('chromium' 'google-chrome')
install="${pkgname}.install"
-source=("https://github.com/bitwarden/browser/releases/download/v${pkgver}/${_distname}")
-noextract=("${_distname}")
-sha512sums=('df00d9a73cc4469b4f136c55e25833349be44366a83eed371217488fe1944b688650623b5671017b28d484516594f8e18977ea52c2cdda2b4c42433fc06d850e')
+source=("${url}/releases/download/browser-v${pkgver}/dist-chrome-${pkgver}.zip")
+noextract=("dist-chrome-${pkgver}.zip")
+sha512sums=('7f17e5488645a4243f372238edff8a42eabdab7b5d8681f48e2164b5891632e713bfaba2bef2cca46d789ae240d28ff599ad112aedb8e53ea8bcc8694ccf1a8f')
package() {
# Extract files - bsdtar doesn't seem to handle it well
cd "${srcdir}"
- unzip "${_distname}"
- rm "${_distname}"
+ unzip "dist-chrome-${pkgver}.zip"
+ rm "dist-chrome-${pkgver}.zip"
# Fix broken permissions
chmod 755 $(find "${srcdir}" -type d)
chmod 644 $(find "${srcdir}" -type f)