summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c797503b359..e1bebf7a009d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=bitwarden_rs-git
_pkgbase=bitwarden_rs
-pkgver=1.16.3.r62.g3777624
+pkgver=1.19.0.r4.gd69be7d
pkgrel=1
-pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
+pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust. Supports all database backends(mysql, postgresql, sqlite) Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
license=('GPL3')
depends=('openssl')
-makedepends=('rust-nightly' 'cargo-nightly' 'git')
-provides=("$_pkgbase")
-optdepends=("bitwarden_rs-vault: Web Interface 'Vault'")
-conflicts=("${_pkgbase}" "${_pkgbase}-mysql" "${_pkgbase}-postgresql")
+makedepends=('rust-nightly' 'cargo-nightly' 'git' 'postgresql-libs' 'mariadb-libs')
+provides=("${_pkgbase}" "${_pkgbase}-"{mysql,sqlite,postgresql})
+optdepends=("bitwarden_rs-vault: Web Interface 'Vault'" "postgresql-libs: For running bitwarden_rs with the postgresql backend" "mariadb-libs: For running bitwarden_rs with the mysql backend")
+conflicts=("${_pkgbase}" "${_pkgbase}-"{mysql,sqlite,postgresql})
backup=('etc/bitwarden_rs.env')
install=bitwarden_rs.install
source=('git+https://github.com/dani-garcia/bitwarden_rs.git'
@@ -26,8 +26,8 @@ sha512sums=('SKIP'
'ae1e05b613d3178bf3fa273ff6661c567140a43826e681b5164ef7d101c1243e5ff93e9caf7193984626d363b8b8b7c076e6646b865699d4cbe482a3dc4f91e7'
'6f6b05881ee3344bdc553fae00a709404ddd086af347f909b3f3a620aabd2294b7dd2892472cd72515e9ceced2449eacbd9ef24626a1429776ea4599673a665b'
'15b00b0dc9122f98ce8d7b55668fdfbb2e0387563e7d9ad6c0ebc73b75e46e1ccdb3a2186a453795a1b3e2d45358ff5a8076d5cf30319ab2c21539d20cff81c6'
- '6fd0ea962f077f92ad7f55a1bab479e68e3463b41eb171d501847554b676b7ecf05e016544f6331bdb53bf71038fcf2ce67ad213d0a7c2f93acbafd72e8441a6'
- 'd3ef28356adb66f3f0b50ef9efdae034f542c3ec486952c01ebdb959c2aa5a00a6aad8b73d57e71eb23db6320b5728ac7b26829f8856e0b7220708b91027f944')
+ '142f9134e14cc90f135fa1e6b0121e6427f2043b07b6543e24f35f5581aebf338feb12991f23563e516de205b19ad3fbae8bdcd9b5cc5a4736798f3c61757aae'
+ '9e0bf89b2e1196402e744244b09257d58958a8fa4b78aabc556571781a1cb05e900e15877f884592e2796c24d631e353d715f202238260055e7d2e8f77cafc58')
pkgver() {
@@ -48,7 +48,7 @@ build() {
cd "$srcdir/$_pkgbase"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
- BWRS_VERSION="$pkgver-archlinux-sqlite-$pkgrel" cargo build --release --locked --features sqlite
+ BWRS_VERSION="$pkgver-archlinux-sqlite-$pkgrel" cargo build --release --locked --features sqlite,postgresql,mysql
rustup set profile $RUSTUP_PROFILE 2>/dev/null && echo "Set rustup profile back to '$RUSTUP_PROFILE'."
}