summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e058ab7f91e7..923a310b38b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,15 @@
pkgbase=bitwuzla
pkgname=("${pkgbase}" "${pkgbase}-doc")
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc='SMT solver for the theories of fixed-size bit-vectors, floating-point arithmetic, arrays and uninterpreted functions and their combinations'
arch=('x86_64')
url='https://bitwuzla.github.io'
license=('MIT')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bitwuzla/bitwuzla/archive/refs/tags/${pkgver}.tar.gz"
- "upstream-gcc14.patch::https://github.com/bitwuzla/bitwuzla/commit/31330f252ace62954d573e68261acd78c8554db7.patch"
"0001-Use-installed-libraries.patch"
"0002-Skip-Test-based-on-timeout.patch"
- "0003-Do-not-require-git.patch" # git is only used to pull not installed dependencies
)
depends=('gcc-libs' 'glibc' 'gmp>=6.1' 'kissat')
makedepends=(
@@ -41,20 +39,16 @@ provides=(
'libbitwuzlabb.so'
'libbitwuzlals.so'
'libbitwuzla.so')
-b2sums=('135ed8dbe8ada22ca36f872ccc062622bfdfa87592cfcad596f9c1c0c92c99a486a7ff52707fe7dba33531405cd6c84a20a3f546d3614585721f6b7468dc2894'
- '60caf89635e0e782e18ca7642a64da55e462720106b50d08c7977edd37954314a7b4fe2230dfdffebb834fcd6a2449fca71d4d9a50c10f3db06cd70e48142a77'
+b2sums=('7fa955bc4a086860f4882e173c5ceb27e03ce0ea1c6cb4561e941af3f7945a258b817dc3cd240241e5b999415c6c41aca41f642d5447611ffd490ed74a489061'
'0ebea6754d4fc270c268d4088af9bcb93596fe5ec7b1065f83d39e5c56eef93d567592443ec0a460a34bf5829b5b54f2c9971644f6fbbebbf9c43a1b440ac54d'
- '7728ab77cb234b4427e7cf493817a24bf97440304efb4fc4300125ec470a0bf15430b4416d3c5fdea51dc91441640d05995ed4a08d4c628f97f4d4dc08538d7e'
- '7c80c06aec86c5c75a72786cfafa03d703950efa5639726abec5466b82928ae231eed75bff29d056d6e47bf2e4ab1ce4f9634fd96f9454d0b92d90c30fd26f37')
+ '7728ab77cb234b4427e7cf493817a24bf97440304efb4fc4300125ec470a0bf15430b4416d3c5fdea51dc91441640d05995ed4a08d4c628f97f4d4dc08538d7e')
options=('!lto')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch --forward --strip=1 --input=../upstream-gcc14.patch
patch --forward --strip=1 --input=../0001-Use-installed-libraries.patch
patch --forward --strip=1 --input=../0002-Skip-Test-based-on-timeout.patch
- patch --forward --strip=1 --input=../0003-Do-not-require-git.patch
}
build() {