summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa9d4815ee06..d112287739f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
-# Maintainer: James Groom <OSSYoshiRulz at gmail dot com>
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: James Groom <OSSYoshiRulz at gmail dot com>
pkgname=bizhawk-monort
_providesName=bizhawk
-pkgver=2.5.2
-_archiveName="BizHawk-2.5.2"
-pkgrel=1
+pkgver=2.9.1
+_archiveName="BizHawk-$pkgver-linux-x64.tar.gz"
+pkgrel=2
pkgdesc="A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)"
arch=("x86_64")
url="https://gitlab.com/TASVideos/BizHawk#readme"
license=("MIT" "custom")
-depends=("glibc" "lsb-release" "mono>=6.10" "openal")
+depends=("glibc" "lsb-release" "lua" "mono>=6.12" "openal")
optdepends=(
- "antimicro: to use unsupported controllers as keyboards"
- "ffmpeg: to use built-in A/V capture, unstable"
+ "antimicro: to use unsupported controllers (by mapping to the keyboard)"
)
-makedepends=("dotnet-sdk>=5.0.0")
provides=("$_providesName=$pkgver")
-source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName.zip")
-sha512sums=("9e4cdf5e2e311ca5ad5750b91ea5163d8e727813f9a88200d80013657c45b33b0a51112fd5816debe264b99b1244b8555c0f8b9eccfc6f87c45e67bbd1c28b06")
+install="bizhawk-monort.install"
+source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName")
+sha512sums=("bec7e558963416b3749ef558bc682d1a874a43df8fe3083224ec7c4c0326cdfea662ef5c604eea7c1743d2eeb13656ccf749f0cdb3a413f4985c4b305a95e742")
package() {
cd "$srcdir"
+ mkdir opt
+ tar -xf BizHawk*.tar.gz -C opt
+ cd opt
find . -type d -exec install -D -ggames -m775 -d "$pkgdir/opt/$_providesName/{}" \;
find . -type f -not -name *.sh -exec install -D -ggames -m664 "{}" "$pkgdir/opt/$_providesName/{}" \;
find . -type f -name *.sh -exec install -D -ggames -m774 "{}" "$pkgdir/opt/$_providesName/{}" \;