summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f57d42a7cee..d67324830a1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
pkgname=blackbox-explorer
_reponame=blackbox-log-viewer
pkgver=3.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Cleanflight and Betaflight Blackbox Explorer (NW.js build)"
arch=("x86_64")
url="https://github.com/betaflight/${_reponame}"
license=('GPL3')
depends=('nwjs-bin>=0.31.0' 'nwjs-ffmpeg-codecs-bin')
-makedepends=('yarn' 'npm' 'git')
-source=("git+https://github.com/betaflight/${_reponame}.git#commit=84f8abd7463e65773921635b57c7ac8fd4104ce9"
+makedepends=('yarn' 'npm')
+source=("https://github.com/betaflight/${_reponame}/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('SKIP'
- '95635caffae7a586612f10abbc8248764ddde4f7192d8ed65d7a3c1e2e689c1d'
- 'bc9ba2824d722c0872d952ffe30b6fc88583eacd97e2c614a28e2847668a4554')
+sha512sums=('873473584c43198b3d4e257d8752836ec6ca3e8764ddb8f4f1c3a5c64366d26530bfdb9ebecd0a3c218315350b6e9fd745a69c961aded9cece404eceb30492ec'
+ 'd5e10ddba597043b75e7a5e02bf23d4bf1c6c64907c9b187e2e48bed045e001abaaec062b39bd9040222d1693758a54112d56d92538cb8b717d2b60d41175fa4'
+ 'c06b498dfa438002ee9f5f4e90276b051762a936057b6b513e207106f727978fd301d8c131ab320cedc50eb86e46f1f8905b867caf1e6d550fda54985a2529ae')
options=(!strip)
build() {
- cd "$_reponame"
+ cd "$_reponame-$pkgver"
yarn install
./node_modules/.bin/gulp dist --linux64
}
package() {
- cd "$_reponame"
+ cd "$_reponame-$pkgver"
install -d "$pkgdir/usr/share/$pkgname/"
cp -r dist/* "$pkgdir/usr/share/$pkgname/"
install -D "assets/linux/icon/bf_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"