summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a83c6002fe71..dc742b4eb8cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=blanket
-pkgver=0.3.1
-pkgrel=4
+pkgver=0.4.0
+pkgrel=1
pkgdesc="Improve focus and increase your productivity by listening to different sounds."
arch=('any')
url="https://github.com/rafaelmardojai/blanket"
license=('GPL3')
depends=('gtk3' 'gst-python' 'python-gobject' 'libhandy')
makedepends=('meson')
+checkdepends=('appstream-glib')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('79942ed919507c0078266d221c433ba9209f8ea5f11371d55d64bd3b469623bf')
+sha256sums=('dc144634e83807b12ac9a2ceeb706816bfe3724c4218e87c63088d53a57fbcc3')
build() {
arch-meson "$pkgname-$pkgver" build
meson compile -C build
}
+check() {
+ meson test -C build
+}
+
package() {
DESTDIR="$pkgdir" meson install -C build
}