summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b28a56606a45..e332c506c85e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=blanket-git
-pkgver=0.6.0.r166.g2059aab
+pkgver=0.7.0.r0.ge707013
pkgrel=1
pkgdesc="Improve focus and increase your productivity by listening to different sounds."
arch=('any')
url="https://apps.gnome.org/Blanket"
license=('GPL-3.0-or-later')
-depends=('gst-plugins-bad-libs' 'gst-plugins-base' 'gst-plugins-good' 'gst-python'
- 'libadwaita' 'python-gobject')
-makedepends=('blueprint-compiler' 'meson' 'git')
-checkdepends=('appstream-glib')
+depends=(
+ 'gst-plugins-bad-libs'
+ 'gst-plugins-base'
+ 'gst-plugins-good'
+ 'gst-python'
+ 'libadwaita'
+ 'python-gobject'
+)
+makedepends=(
+ 'blueprint-compiler'
+ 'git'
+ 'meson'
+)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/rafaelmardojai/blanket.git")
+source=('git+https://github.com/rafaelmardojai/blanket.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
-}
-
build() {
arch-meson "${pkgname%-git}" build
meson compile -C build