summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28065b4ced77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+pkgname=blender-plugin-animation-nodes
+name=animation_nodes
+pkgver=2.0
+pkgrel=1
+pkgdesc="Node based visual scripting system designed for motion graphics in Blender."
+arch=('x86_64')
+url="https://github.com/JacquesLucke/animation_nodes"
+license=('GPL')
+depends=(blender python-numpy)
+makedepends=(cython)
+options=()
+source=("https://github.com/JacquesLucke/animation_nodes/archive/v2.0.tar.gz"
+ )
+md5sums=('a5e8d144323c4302b2dab8dca1b61b7d')
+
+build() {
+ cd ${srcdir}/${name}-${pkgver}
+ python setup.py --nocopy --noversioncheck
+}
+
+package() {
+ cd ${srcdir}
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ install -d 755 ${addons}/${name}
+ cp -a -t ${addons}/${name} ${name}-${pkgver}/${name}/*
+}
+
+# vim:set sw=2 ts=2 et: