summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7fd81059824..4c1d31513525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="luxcorerender"
pkgname=blender-plugin-${_name}
pkgver=2.3
epoch=2
-pkgrel=1
+pkgrel=2
pkgdesc="LuxCoreRender exporter plugin for Blender"
arch=('any')
url="https://luxcorerender.org/"
@@ -14,7 +14,7 @@ license=('GPL')
source=("https://github.com/LuxCoreRender/BlendLuxCore/archive/blendluxcore_v${pkgver}.tar.gz"
"denoise.patch")
sha256sums=('a5ea3dbac4e56decef5561ceb456be3eb6658111dd8feed55d632a52bfd7edaa'
- '63103ec3bf77c502a54f6f74cad020a448c9641be90202944c46bda0a1ff8bfe')
+ '118853c17d90f034e0f6e3b1e07f7d3042bc7c706c46cfb3c2dd13242e1c6ce0')
prepare() {
cd "${srcdir}/BlendLuxCore-blendluxcore_v${pkgver}"
@@ -25,7 +25,7 @@ package() {
depends=("blender>=2.80" "luxcorerender>$pkgver")
_blender=$(pacman -Sddp --print-format %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=)')
install -d -m755 "${pkgdir}"/usr/share/blender/"${_blender}"/scripts/addons
- cp -a "${srcdir}"/BlendLuxCore-blendluxcore_v${pkgver} "${pkgdir}"/usr/share/blender/${_blender}/scripts/addons/${_name}
+ cp -a "${srcdir}"/BlendLuxCore-blendluxcore_v${pkgver} "${pkgdir}"/usr/share/blender/"${_blender}"/scripts/addons/${_name}
# change the search path in exporter so it finds pylux in its new location :(previous solution was much better, what happen to blendlux )
#sed -i 's|from.*import pylux|import pylux|' "$pkgdir/usr/share/blender/$_blender/scripts/addons/luxrender/outputs/pure_api.py"
# shellcheck disable=SC2013 # works until path has no white space.