summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e69de29bb2d1..eb86874b288e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexis ViguiƩ <alexis.viguie@epitech.eu>
+pkgname=blih
+pkgver=1.7
+pkgrel=1
+pkgdesc="Bocal Lightweight Interface for Humans, git repositories and
+SSH public keys management tool for EPITECH students"
+arch=('any')
+url="https://intra-bocal.epitech.eu"
+license=('GPL')
+groups=()
+depends=('python>=3.3.0' 'python-requests')
+makedepends=()
+optdepends=()
+provides=('blih')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://pkg.blinux.fr/pub/$pkgname/$pkgver/$pkgname-$pkgver.tgz)
+noextract=()
+md5sums=('8d737cc043bcd2217cfb89ab84882ceb')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cat blih.py | sed -e s/python3.3/python/ > blih
+ chmod 755 blih
+}
+
+package() {
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ cp "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin"
+}