summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 456cad4b70cb..ddfd46be3955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,27 @@
# Maintainer: Jonas 'cherti' Große Sundrup <aur@letopolis.de>
pkgname=blinky
-pkgver=0.15.2
+pkgver=0.23.2
pkgrel=1
pkgdesc="AUR-helper with minimal hassle"
arch=(any)
url="https://github.com/cherti/blinky"
license=('GPLv3')
-depends=('python' 'pyalpm' 'python-requests' 'python-termcolor' 'colordiff')
+makedepends=(python-build python-installer python-wheel)
+depends=('python' 'pyalpm' 'python-requests' 'python-termcolor' 'python-pyxdg' 'python-packaging' 'colordiff' 'wget')
+optdepends=('libnotify')
options=(!emptydirs)
-source=('https://github.com/cherti/blinky/archive/v0.15.2.tar.gz')
-sha256sums=('a5d8ecde62681fabf9bf166c9dd5f1efefb7933511a110da342a34efa7146760')
+source=('https://github.com/cherti/blinky/archive/v0.23.2.tar.gz')
+sha256sums=('579f3a4e728c2ba51ea79e14adfe7e09887d48f79ab099a07cc1029f31083f03')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 completion/_blinky "$pkgdir/usr/share/zsh/site-functions/_blinky"
}