summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 7 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb0e71dd0246..6f8c7ded4583 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,12 @@
-# $Id$
-# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer:
-pkgname=bluez-hciconfig
-pkgver=5.66
+_newpkg='bluez-tools-extra'
+pkgname='bluez-hciconfig'
+pkgver=5.67
pkgrel=1
-pkgdesc="deprecated hciconfig tool from bluez"
-url="http://www.bluez.org/"
-arch=('x86_64')
-license=('GPL2')
-depends=("bluez-libs")
-source=(https://www.kernel.org/pub/linux/bluetooth/bluez-${pkgver}.tar.xz)
-sha256sums=('39fea64b590c9492984a0c27a89fc203e1cdc74866086efb8f4698677ab2b574')
-
-build() {
- cd bluez-${pkgver}/tools
- gcc hciconfig.c parser/{csr,parser,lmp}.c ../src/textfile.c \
- -lbluetooth -o hciconfig \
- -DVERSION=\"$pkgver\" \
- -DSTORAGEDIR=\"/var/lib/bluetooth\" \
- -I..
-}
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
package() {
- cd bluez-${pkgver}/tools
- install -Dm0755 hciconfig "$pkgdir"/usr/bin/hciconfig
- install -Dm0755 hciconfig.1 "$pkgdir"/usr/share/man/man1/hciconfig.1
+ depends=("$_newpkg")
}