summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 805e5e5a2c46..dd981f148d52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,30 @@
pkgname='bluez-utils-compat'
_pkgbase='bluez'
-pkgver=5.58
+pkgver=5.59
pkgrel=1
url="http://www.bluez.org/"
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
license=('GPL2')
pkgdesc="Development and debugging utilities for the bluetooth protocol stack. Includes deprecated tools."
depends=('dbus' 'systemd' 'glib2')
-makedepends=('dbus' 'libical' 'systemd' 'alsa-lib' 'json-c' 'ell')
+makedepends=('dbus' 'libical' 'systemd' 'alsa-lib' 'json-c' 'ell' 'python-docutils')
optdepends=('ell: for btpclient')
conflicts=('bluez-hcidump' 'bluez-utils' 'bluez-hcitool')
provides=('bluez-hcidump' "bluez-utils=${pkgver}" 'bluez-hcitool')
-source=(https://www.kernel.org/pub/linux/bluetooth/"${_pkgbase}-${pkgver}".tar.xz) #{xz,sign}
+source=(https://www.kernel.org/pub/linux/bluetooth/"${_pkgbase}-${pkgver}".tar.xz #{xz,sign}
+ 0001-rfkill-Fix-reading-from-rfkill-socket.patch)
# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
-sha256sums=('c8065e75a5eb67236849ef68a354b1700540305a8c88ef0a0fd6288f19daf1f1')
+sha256sums=('046b95b386d0bfb2a16311fe799d517ee7735045512d89902c4ed701db477316'
+ 'befc9c56fa15fe276916d299e70901d09aedc25d5a29ee444e78fa76f297e72f')
#validpgpkeys=('E932D120BC2AEC444E558F0106CA9F5D1DCF2659') # Marcel Holtmann <marcel@holtmann.org>
+prepare() {
+ cd "${_pkgbase}"-${pkgver}
+ # https://bugs.archlinux.org/task/71243
+ patch -Np1 -i ../0001-rfkill-Fix-reading-from-rfkill-socket.patch
+}
+
build() {
cd "${_pkgbase}-${pkgver}"
./configure \