summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69a3bd81351c..fecdb93da10f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
_pkgbase=bmi160-aya-neo
pkgname=${_pkgbase}-dkms-git
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
-pkgdesc='BMI160 DKMS driver for devices with 10EC5280 ACPI ID'
+pkgdesc='BMI160 DKMS driver patch for devices with 10EC5280 ACPI ID'
arch=(any)
url=https://github.com/pastaq/bmi160-aya-neo
license=(GPL3)
depends=()
-makedepends=(dkms git wget linux-headers)
+makedepends=(curl dkms git linux-headers)
source=(git+"${url}".git)
sha256sums=('SKIP')
package() {
cd "${srcdir}"/"${_pkgbase}"
- local install_dir="${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
-
- install -Dm644 bmi160_ayaneo.patch "${install_dir}/bmi160_ayaneo.patch"
- install -Dm644 bmi160_i2c-mods.conf "${install_dir}/bmi160_i2c-mods.conf"
- install -Dm644 dkms.conf "${install_dir}/dkms.conf"
- install -Dm755 dkms-patchmodule.sh "${install_dir}/dkms-patchmodule.sh"
- install -Dm755 dkms.post_install "${install_dir}/dkms.post_install"
- install -Dm755 dkms.post_remove "${install_dir}/dkms.post_remove"
- install -Dm644 Makefile "${install_dir}/Makefile"
-
+ local install_dir="${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+
+ install -Dm644 bmi160_ayaneo.patch "${install_dir}/bmi160_ayaneo.patch"
+ install -Dm644 dkms.conf "${install_dir}/dkms.conf"
+ install -Dm755 dkms-patchmodule.sh "${install_dir}/dkms-patchmodule.sh"
+
# Set name and version
- sed -e "s/@_PKGBASE@/${_pkgbase}/" \
- -e "s/@PKGVER@/${pkgver}/" \
- -i "${install_dir}"/dkms.conf
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${install_dir}"/dkms.conf
}