summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 20 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bf5cc0989b0..8fdc3da0267b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,30 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Emilio Reggi <nag@mailbox.org>
-
pkgname=bombadillo
-pkgver=2.3.3
-pkgrel=2
-pkgdesc="A non-web client for the terminal, supporting Gopher, Gemini and much more."
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="A non-web client for the terminal, supporting Gopher, Gemini and much more"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
-url="https://bombadillo.colorfield.space"
-license=('GPL3')
-depends=('glibc')
-makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::https://tildegit.org/sloum/bombadillo/archive/$pkgver.tar.gz"
- 001-Makefile.patch)
-sha256sums=('2d4ec15cac6d3324f13a4039cca86fecf3141503f556a6fa48bdbafb86325f1c'
- 'a379b36f6ba85a689942f90f9f4f4d416678f34c1e99bdbb8eaeadaaf6f0b788')
-
-prepare() {
- patch -p1 -d "$pkgname" < 001-Makefile.patch
-}
+url="https://${pkgname}.colorfield.space"
+license=(GPL3)
+depends=(glibc)
+makedepends=(go)
+source=(${pkgname}.tar.gz::https://tildegit.org/sloum/${pkgname}/archive/${pkgver}.tar.gz)
+sha512sums=('ce9ac62e2d57d98c6acca35b0a054a7920ad2ea8fa315b11c881057d30022f3417cf8132cfd1e6038410ca8aef9d430eb946ed803b62a4a52d2ac64f71dd3a1a')
build() {
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd "$pkgname"
- make PREFIX=/usr
+ cd ${pkgname}
+ make PREFIX=/usr
}
package() {
- cd "$pkgname"
- make VERSION="$pkgver" DESTDIR="$pkgdir/" PREFIX=/usr install
+ cd ${pkgname}
+ make VERSION="${pkgver}" DESTDIR="${pkgdir}/" PREFIX=/usr install
}